Bank of Ireland Open Banking - Degraded performance with Aggregation
Incident Report for Tink providers Ireland
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 15:49 UTC
Investigating
We are currently investigating an issue with Bank of Ireland.
Posted Feb 12, 2024 - 10:33 UTC
This incident affected: Bank of Ireland.