Bank of Ireland Business - Major outage
Incident Report for Tink providers Ireland
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Mar 30, 2024 - 11:51 UTC
Identified
We have identified the issue and are in contact with Bank of Ireland for further information.
We will update when a significant change to the situation occurs.
Posted Mar 29, 2024 - 17:26 UTC
This incident affected: Bank of Ireland.